Check the Obsolescence Notice

Because hardware and software evolve, some boards, tools and features are becoming obsolete. As a consequence, development and support are either put on hold or discontinued.

Please refer to the other sections of this chapter for additional information.

Check Boards

Some boards are ageing and are no longer supported by their standard IDEs.

Energia 16 no longer supports the LaunchPad MSP430G2 with MSP430G2331 and MSP430G2442 MCUs.

Warning

Energia 18 no longer supports the LaunchPad C2000, the SensorTag CC2650.

The chipKIT UC32 board replaces the chipKIT Uno32 board.

Intel has announced it will end support the Galileo, Edison and Curie boards mid-December 2017.

As a consequence, development is halted.

embedXcode continues to support the latest available releases of the tools for those boards.

Check IDEs and Plug-Ins

 Support for Arduino.CC and Arduino.ORG IDEs is discontinued.

The unified Arduino 1.8.0 IDE corresponds to release 1.8.0 and supports all the boards from former Arduino.CC and Arduino.ORG.

All releases of the Arduino IDE previous to 1.8, including 0023, 1.0 and 1.5, and series 1.6 and 1.7, are deprecated and not longer supported.

The Arduino Boards Manager replaces previous plug-ins.

The Adafruit, chipKIT, Cosa, Digistump, ESP8266, Intel, Little Robot Friends, panStamp, RedBear, RFduino boards used to require plug-ins or specific IDEs.

They are now managed by the Boards Manager of the Arduino.CC 1.6.5 IDE. The previous stand-alone IDEs and plug-ins are no longer supported.

Support for MPIDE is discontinued.

The chipKIT boards are now managed by the Boards Manager of the Arduino.CC 1.6.5 IDE. The previous stand-alone IDE, MPIDE, is no longer supported.

 Support for Energia prior to 1.6.10E18 is discontinued.

Release 1.6.10E18 features the same clean management of additional boards as Arduino.CC 1.6.5 with the Boards Manager.

The versions of Energia IDE prior to release 1.6.10E18 are obsolete and no longer supported.

Check Frameworks

 Support for Arduino 0023, 1.0, 1.5, 1.6 prior to release 1.6.5 is discontinued.

Arduino 0023, 1.0 and 1.5 are deprecated. Arduino 1.6.5 offers a clean management of additional boards, widely adopted by third-party boards manufacturers.

The Arduino IDE versions prior to release 1.8.0 are obsolete and no longer supported.

 Support for Maple boards is put on hold.

Leaflabs no longer supports the Maple boards.

The Maple IDE still lacks very basic but critical libraries such as stream and strings. Use instead the STM32duino boards package compatible with the Arduino 1.6.5 Boards Manager.

 Support for Wiring boards is put on hold.

Wiring is said to be working on a new release, called Wiring++, but with no specific release date.

Support for the Wiring boards will resume when an updated IDE is available.

 Development for the Digistump platform is put on hold.

The Digistump platform suffers from many stability issues, especially for the Oak board.

Development for the Digistump platform is put on hold and will resume when more mature hardware is available.

 Development for the Particle platform is put on hold.

Particle strongly promotes its on-line IDE. Unfortunately, the command line tools don't offer the required level of stability.

Development for the Particle platform is put on hold and will resume when updated command line tools are available.

 Support for mbed is discontinued.

The mbed SDK is going through a major reshuffle, with the release of mbedOS, leaving some issues unattended on today's version, rebranded mbed Classic. Furthermore, the latest mbed Classic updated releases are incompatible and unstable. Latest stable release of the mbed SDK with Bluetooth capabilities is 92.

 Support for BeagleBone is discontinued.

Most of the development tools for BeagleBone are designed for a main computer running on Linux. Building a tool-chain from scratch on Mac OS X is overtly difficult, and very few ready-to-use binaries are available for Mac OS X.

 Development for the Little Robot Friends platform is put on hold.

Little Robot Friends no longer supports the first generation of boards with the release of the second generation.

 Development for the Glowdeck platform is put on hold.

 Support for the Cosa framework is put on hold.

The latest release is dated January 30, 2016 and the project doesn't seem to be maintained anymore.

Please refer to the Use Discontinued Wiring / Arduino Frameworks section.

Check macOS and Xcode

 Both macOS and Xcode are available as free updates for most systems, with macOS 10.13 High Sierra and Xcode 9 on macOS 10.12 Sierra and macOS 10.13 High Sierra

 embedXcode for Xcode 8 on macOS 10.11 El Capitan and Mac OS X 10.12 Sierra is no longer developed and has limited support.

A legacy edition of embedXcode Legacy 8 for both standard and plus editions, is available for Xcode 8 on macOS 10.11 El Capitan and Mac OS X 10.12 Sierra, and corresponds to release 7.6.8.

 embedXcode for Xcode 7 on Mac OS X 10.10 Yosemite and 10.11 El Capitan is deprecated and no longer supported

A legacy edition of embedXcode Legacy 7 for the plus edition, is available for Xcode 7 on Mac OS X 10.10 Yosemite and 10.11 El Capitan and corresponds to release 4.5.6.

All previous releases of embedXcode are deprecated and no longer supported.